You are here: Cops>Common Web>DevNotes (2013-08-15, RaymondLutz)Edit Attach

Dev Notes

To install Gauge plugin, need
  • libgd
  • libpng

----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

Confirmed it /usr/local/lib is included in /etc/ld.so.conf

But needed to add it to path

# PATH=$PATH:/usr/local/bin
# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin://bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

cpan now finds gdlib on path BUT fails most test.

used command:
  • force install GD

Topic revision: r2 - 2013-08-15, RaymondLutz
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Cops? Send feedback